admin 发表于 2018-6-20 20:57:36

.net FrameWork数据提供程序要求 Microsoft Data Access Components (MDAC) 。请安...

.net FrameWork数据提供程序要求 Microsoft Data Access Components (MDAC) 。请安装Microsoft Data Access Components(MDAC)2.6或更高版本


vs2005 + vb.net + oracle + ado.net 开发的程序,在一个客户的机器上出现错误:
.net FrameWork数据提供程序要求 Microsoft Data Access Components (MDAC) 。请安装Microsoft Data Access Components(MDAC)2.6或更高版本
拿来了mdac2.8 安装,提示不能在当前版本上安装。下载了 mdac2.7,安装成功,
但是依然出现刚才的错误。
在网上查到了有的网友这样的解决经历:
【winxp+vs2005+access做的程序,运行时提示.NetFrameworkOleDb数据提供程序要求MicrosoftDataAccessComponents(MDAC)2.6或更高版本。发现当前安装的版本是2.50.4403.12。,安装了Mdac2.7以后重启,无济于事,说明不是版本的问题,可能是个bug。

    解决办法:HKEY_LOCAL_MACHINE/Software/Microsoft/DataAccess下所有键值为2.50.4403.12的都根据你安装的版本改成高版本的版本号 ,我的为2.71.9040.2,然后再运行,问题解决】
我在这台机器上参照做了,但是依然出现刚才的错误。
有查到另一个网友的解决经历:【
第一、打开"c:/windows/inf"注意:“inf”是隐藏目录。
         找到文件“mdac.inf”。鼠标点击右键——> 安装 。
第二、提示要“I386文件夹中的文件”,插入windows xp 安装盘(或为网上下在windows I386 文件。)

安装完,就ok了!

照着做了以便,果然问题解决了。
页: [1]
查看完整版本: .net FrameWork数据提供程序要求 Microsoft Data Access Components (MDAC) 。请安...